반응형
1) 문제
https://www.acmicpc.net/problem/2075
N×N의 표에 수 N2개 채워져 있다. 채워진 수에는 한 가지 특징이 있는데, 모든 수는 자신의 한 칸 위에 있는 수보다 크다는 것이다. N=5일 때의 예를 보자.
12 | 7 | 9 | 15 | 5 |
13 | 8 | 11 | 19 | 6 |
21 | 10 | 26 | 31 | 16 |
48 | 14 | 28 | 35 | 25 |
52 | 20 | 32 | 41 | 49 |
이러한 표가 주어졌을 때, N번째 큰 수를 찾는 프로그램을 작성하시오. 표에 채워진 수는 모두 다르다.
입력
첫째 줄에 N(1 ≤ N ≤ 1,500)이 주어진다. 다음 N개의 줄에는 각 줄마다 N개의 수가 주어진다. 표에 적힌 수는 -10억보다 크거나 같고, 10억보다 작거나 같은 정수이다.
출력
첫째 줄에 N번째 큰 수를 출력한다.
예제 입력 1 복사
5
12 7 9 15 5
13 8 11 19 6
21 10 26 31 16
48 14 28 35 25
52 20 32 41 49
예제 출력 1 복사
35
2) 내가 구현한 코드
import java.util.*;
import java.io.*;
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
StringTokenizer st;
int N = Integer.parseInt(br.readLine());
PriorityQueue<Integer> pq = new PriorityQueue<>(Collections.reverseOrder());//최대힙
//힙에 모든 수 넣기
for(int i = 0; i < N; i++) {
st = new StringTokenizer(br.readLine());
for(int j = 0; j < N; j++) {
int num = Integer.parseInt(st.nextToken());
pq.add(num);
}
}
//N-1번째까지 높은 우선순위 제거
for(int i=0; i<N-1; i++){
pq.poll();
}
bw.write(""+pq.poll());
bw.flush();
br.close();
bw.close();
}
}
3) 추가 구현 코드
import java.io.*;
import java.util.*;
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
int N = Integer.parseInt(br.readLine());
PriorityQueue<Integer> queue = new PriorityQueue<>();
for (int i = 0; i < N; i++) {
StringTokenizer st = new StringTokenizer(br.readLine());
for (int j = 0; j < N; j++) {
int num = Integer.parseInt(st.nextToken());
queue.add(num);
if (queue.size() > N) {
queue.poll();
}
}
}
System.out.println(queue.peek());
}
}
3) 추가 문제
미들러 - 모의고사
https://school.programmers.co.kr/learn/courses/30/lessons/42840
챌린저 - 소트
https://www.acmicpc.net/problem/1083
반응형
'coding_test' 카테고리의 다른 글
[99클럽 4기 코테 스터디 TIL 22일차] 2558. Take Gifts From the Richest Pile (feat. 최대힙, Math.sqrt(), Math.floor()) (0) | 2024.11.19 |
---|---|
[99클럽 4기 코테 스터디 TIL 21일차] 센티와 마법의 뿅망치 (feat. 최대힙) (0) | 2024.11.18 |
[99클럽 4기 코테 스터디 TIL 19일차] 최소 힙 (feat. PriorityQueue) (1) | 2024.11.16 |
[99클럽 4기 코테 스터디 TIL 18일차 보너스문제] 다리를 지나는 트럭 (feat. 큐) (0) | 2024.11.16 |
[99클럽 4기 코테 스터디 TIL 18일차] 식당 입구 대기 줄 (feat. 스택으로 식당 줄 서기) (1) | 2024.11.15 |